Sunday, March 05, 2006

Tech Tip: YouTube & Bebo

So, after getting into the social networking [wikipedia.org] thing, I've been thinking about the FAQ and help sections of these websites [facebook.com][bebo.com]. The FAQ/help sections of these websites often doesn't list details of how some of their technologies actually work. Point in case being bebo's 'flashbox' technology.

Instead of being like the rest of the 'beboers', why not add your own semi-unique flashbox by using YouTube [youtube.com].

Its pretty simple. Every video on YouTube [youtube.com] is identified by a unique bunch of letters and numbers. (eg ZRXLJp0BP9w). Bebo requires an internet url for the location of a beboer's flashbox. YouTube provides an interface to all of its video's by one player.swf file.

So, to get the video from YouTube onto your bebo profile, simply copy the random bunch of letters and numbers from the address bar of your browser and attach it to the end of this url:

http://www.youtube.com/p.swf?video_id=

For our earlier example, Dillinger Escape Plan's 'Panasonic Youth' (ZRXLJp0BP9w) the url would be:

http://www.youtube.com/p.swf?video_id=ZRXLJp0BP9w

Paste this into the bebo flashbox url and click 'save'. That's it, you're done. Enjoy the video you've just picked!

(For examples of two flashboxes done using this technique, check my bebo profile here [bebo.com] or my college class' bebo profile)

[Updated 29/Apr/2006 to reflect the change in swf file used by YouTube...]


72 Comments:

Anonymous Anonymous said...

"Paste this into the bebo flashbox url and click 'save'. That's it, you're done. Enjoy the video you've just picked!"

Thanks for the help - I followed the instructions and loaded my video, however it does not play, it only says "loading"

- I gave it about 20 minutes to see if anything would load but nothing. I've done the same with 3 videos now, all varying in size.

Perhaps I'll try again tomorrow.

Cheers for the tutorial, I really appreciate the help.

From a bebo addict

3/11/2006 10:14 PM  
Blogger shaner said...

hey,

as far as i know this is a problem with youtube. this happened me on one of the videos i loaded. stick with one video for a day or two and if it doesn't change from that 'loading...' screen double-check the random part of the url...

shaner

3/12/2006 8:03 AM  
Anonymous Anonymous said...

Thanks shaner ;)

Will do

3/12/2006 9:55 PM  
Anonymous CrazyD said...

heh! worked 1st time - im SOOOOO happy XD XD XD XD XD

3/13/2006 12:08 PM  
Anonymous Anonymous said...

Thanks man, I've been trying to figure out how to do that for ages becuase I had this video I took at a concert in Germany that I wanted to show my friends :)

3/13/2006 3:50 PM  
Anonymous Anonymous said...

some of you guys were wondering why when you paste in ur random letters and numbers it just says, loading, well i found out, purely by default, that this is caused because u have posted it as private, if you want to bebo it, it has to be public!

3/22/2006 2:03 PM  
Anonymous Anonymous said...

fukin skilled, worked first time, thnx dude

3/24/2006 4:33 AM  
Anonymous Anonymous said...

thank you! youre a legend bro

3/27/2006 2:33 AM  
Anonymous Anonymous said...

You are a star! Cheers

3/29/2006 2:52 PM  
Anonymous chris said...

DUDE U ROCK!!! I got me and me girls song on there now .\m/. thx man!

3/30/2006 2:28 PM  
Anonymous Pete said...

hi there,
you know how to do the same for my clip which is on google video? i can't seem to figure out the swf for putting it on my bebo flashbox!!
clip is at:
http://video.google.com/videoplay?docid=-8659379947974474911&q=new+zealand+bungy&pl=true
any help appreciated!
pete

3/31/2006 7:34 AM  
Anonymous Anonymous said...

How wud u upload a song in to the flash swf space?

4/01/2006 12:00 PM  
Blogger shaner said...

getting a google video for your flashbox is slightly harder than straight from youtube.

if you download the video in avi format (from google video) and then submit it to youtube (does require a free youtube account though...) you can use these instructions.

youtube has recently clamped down on videos over 10 minutes in length though due to the large amounts of full (copyrighted) episodes and movies people were uploading.

an mp3 would require converting the mp3 to a swf file and then doing the same.

i wouldn't advocate uploading content to youtube you don't own the copyright on though ;)

4/03/2006 10:01 AM  
Blogger Ed said...

How do you get it to NOT autoplay? The default YouTube behaviour is to present a play button, but when using this method it doesn't happen. Any suggestions?

4/04/2006 1:31 AM  
Blogger shaner said...

The player.swf that this method uses is a different interface to the youtube videos than the one on the youtube site.

I'm not sure why it is this way. Apparently though, there is an unpublished xml api for youtube which, if they release it, hopefully would enable people to create new styles of players to interact with the youtube video data.

One suggestion might be to email youtube about it. Despite the size of the site youtube is a fairly new internet site...they've only been around since February 2005 so they're likely to still listen to feedback!

4/04/2006 10:45 AM  
Anonymous Anonymous said...

HOW DO I MAKE IT PUBLIC NOT PRIVATE WHEN I POST IT COZ IT JUST SAYS LOADING??!

4/04/2006 11:15 AM  
Anonymous Anonymous said...

HOW DO I MAKE IT PUBLIC NOT PRIVATE SO THAT IT CAN PLAY ON BEBO, BECAUSE IT JUST KEEPS SAYING LOADING??!!

4/04/2006 11:15 AM  
Blogger danee said...

This comment has been removed by a blog administrator.

4/07/2006 10:12 AM  
Blogger danee said...

Hi.... i was wondering if its possible to put Google Videos on to a Bebo flashbox...

i've been playing around with google's source codes, but bebo limits the length of a flashbox link, and Googles video links seem far too long.

But maybe im looking at the wrong place... please get back, dan.

ps: i see that someone else has already ask, but i preferably want google's actual video player on my bebo.... ? i have already signed up to youtube and uploaded my video, but it stutters, unlike when played on google.

4/07/2006 10:28 AM  
Blogger shaner said...

I'm currently looking into how to get Google Video's to work with YouTube. There are a number of advantages to having the google player (ie video not starting immediately...)

The url that the google 'Embed' link gives is too long.

Bebo have added an 'Upload your own video' link recently.

I will post a new tutorial (Google Video specific) when I get it to work.

4/08/2006 9:34 AM  
Anonymous Anonymous said...

Hi, i followed all your instrustions but still this message came up: The SWF http://www.youtube.com/player.swf?video_id=ZRXLJp0BP9w doesn't appear to exists. Please check that it is entered correctly

can you help me out please

4/10/2006 9:07 AM  
Anonymous Anonymous said...

Man, it was working yesterday, now I get a message that says the swf doesn't appear to exist? Any ideas?

4/10/2006 9:19 AM  
Anonymous Terria said...

I've followed all the directions on putting a video on my page but the thing keeps saying
The SWF http://www.youtube.com/player.swf?video_id=ZRXLJp0BP9w doesn't appear to exists. Please check that it is entered correctly...so please help me understand what is wrong.

4/10/2006 9:28 AM  
Anonymous Anonymous said...

Strange stuff, it was working fine yesterday. Youtube was down this morning so maybe they change something to prevent beboers abusing their bandwidth?

The one I was already using in my profile seems to work fine but it's not possible to add a new one anymore.

Anybody heard anything?

4/10/2006 2:43 PM  
Anonymous Anonymous said...

Hi again,
Just letting you know that it's working now... must just have been youtube updating their site or whatever.

4/11/2006 1:34 AM  
Blogger shaner said...

yeah, youtube was down yesterday disrupting alot of people's flashboxes.

i don't think that youtube would prevent beboers from using their video's on the site, it simply wouldn't make sense for them to do that. all of a sudden beboers would be switching to a different service (not a good thing for youtube in the least).

thanks for the comments

4/11/2006 5:08 AM  
Blogger Patrick said...

It doesn't work!! It says load but it never loads!! Is it a problem is my browser (tried with Mozilla Firefox and interent explorer) or something else

4/15/2006 12:42 PM  
Blogger Patrick said...

OUPs It works!! YOU'RE GREAT. I'll promised €2 to anyone that could do it for me, if only I could send it to you!

4/15/2006 12:47 PM  
Anonymous kristina said...

hi it just says loading what am i suppose to do now?

4/17/2006 12:47 AM  
Anonymous Anonymous said...

Hey how come it only says *loading* and does'nt ever load?
plz tell me.

4/17/2006 11:10 PM  
Anonymous Dublin Ger said...

Cheers worked fine!

4/18/2006 12:03 PM  
Blogger shaner said...

The 'loading...' problem was dealt with in the comments previously, but just to clarify I've written a short post about that issue here

4/18/2006 2:42 PM  
Anonymous CC said...

is there any way to center the video? or make the whole thing appear in the flashbox. the video gets cut off on the bottom and top. or i think on all sides haha so is their any way to fix that?

4/18/2006 3:11 PM  
Anonymous Anonymous said...

how do i save utube videos on my computer? coz i wana play youtube vids usin this new egg thing, it seems clearer

4/20/2006 5:21 PM  
Blogger mikomi said...

so whats up with all the videos on bebo? i dont see anybodys working at all

4/28/2006 9:40 PM  
Blogger shaner said...

ok, so YouTube have decided to change the name of their player.swf to p.swf. This essentially breaks the instructions posted here.

I'm not going to dicuss the reasons behind this here, but I'll change the tutorial to reflect this change.

shaner

4/29/2006 5:51 AM  
Blogger mikomi said...

well i did the p.swf now, but it still wont work, its got the different player now but it still says loading

4/29/2006 8:10 AM  
Anonymous Ger said...

yea mine comes up with the play button but dont play after that shitty that it wont autoplay when your page loads anymore

4/30/2006 7:42 AM  
Blogger mikomi said...

yea, mines not playing at all...none of my friends are either

4/30/2006 11:23 AM  
Anonymous Anonymous said...

Same problem with me. Youtube were doing things to the site the other day so methinks they've done something to stop Beboers using their vids for flashboxes :(

4/30/2006 4:43 PM  
Blogger shaner said...

It appears that YouTube have changed the way the player swf file works. It needs to have a reference coming from the YouTube website for the file to play.

Instructions will be posted in a seperate post...

5/01/2006 7:52 AM  
Blogger shaner said...

The updated method is here

5/01/2006 8:03 AM  
Blogger mikomi said...

alright it worked...thanks man

5/01/2006 12:43 PM  
Anonymous Anonymous said...

you're a star

5/01/2006 4:13 PM  
Anonymous Anonymous said...

Hate to be annoying...
But the ones I added using your new method worked fine yesterday, but wouldn't work today? Then when I readded them today using the same method, they worked again?

5/02/2006 3:01 AM  
Blogger shaner said...

If they're working now, leave them be.

I don't work for YouTube or have any insider knowledge, I'm figuring these things out as I go along.

shaner

5/02/2006 8:18 AM  
Anonymous Anonymous said...

No, they're not working now. They work when you add them, but when you close the browser and reopen, it doesn't work any more.

But anyway, it doesn't matter... found an alternative.

Thanks

5/02/2006 11:10 AM  
Blogger mikomi said...

so yea they arent working...again...any solutions?

5/03/2006 6:04 PM  
Anonymous Anonymous said...

hey. youtube on bebo isnt working i think... i tried the updated way of doing it but still doesnt work! any more solutions?

5/04/2006 8:57 AM  
Anonymous Anonymous said...

i followed all the instructions u said to do but it says its still loading i dont know why it keep saying that can u get back at me

5/08/2006 1:04 PM  
Anonymous daisy said...

1. Find the video you would like to use on YouTube
2. Open up a new browser window and paste this: http://www.youtube.com/watch_video?v= but don’t go to it.
2. Go back into YouTube and copy the identifying code from the address bar of your web browser, everything AFTER the ?v= part.
3. Paste the code onto the end of the link in the other browser window and go to it.
4. The link has now changed. Copy it.
5. Paste the new link into the Bebo Flash Box SWF URL box.

THIS WORKS

5/19/2006 5:17 AM  
Anonymous Anonymous said...

wen i followed ur instructions it worked. but then it said loading and nothing loaded lol helpppp!!!

5/19/2006 9:43 AM  
Anonymous Anonymous said...

it works but it there anyway to get it to autoplay when the page is opened up?

5/28/2006 11:12 AM  
Blogger Franziska Jessica said...

Alrite once and for all cos I know loads of people seem to be having this problem. we followed all your instructions and a few videos I have uploaded and tried to get to work on bebo were all public and I put in the correct swf file because it loaded up and started playing, but after a while it won't and just says loading.
I'm starting to think that youtube and bebo just dont go together anymore!
Anyone got any ideas?

5/29/2006 8:23 AM  
Anonymous Anonymous said...

Hey this old method seems to be working again! at least for now...

6/12/2006 3:04 AM  
Blogger michael said...

looks like bebo made it easier to post YouTube videos, there is now a link under the Flash box editor - you just copy the YT URL in and it figured out how to convert the URL

has anyone figured out if its possible to embed the videos into the regular blog area on bebo? that would be even more amazing because the flash box only allows one video

6/12/2006 1:19 PM  
Anonymous Anonymous said...

Hey it works again!

6/12/2006 3:17 PM  
Anonymous Anonymous said...

bebos flashbox is now bebo tv i cant get this to work!

7/20/2006 11:31 PM  
Anonymous Anonymous said...

wher do u paste it?

9/24/2006 8:48 AM  
Anonymous Anonymous said...

where do you find the bebo flashbox url

10/05/2006 1:09 PM  
Anonymous Anonymous said...

Hey, my problem is that I can upload videos from youtube no problem and can view them no problem on youtube. But when I look at my own profile on bebo and most other peoples profiles the video just isnt there. When I click "view" it goes to another screen and claims the video is playing but it isnt on the screen. Help!

12/19/2006 5:42 AM  
Anonymous Anonymous said...

HOW DO I LOAD A VIDEO FROM MY FILE!!!!!!!!!

1/03/2007 9:47 AM  
Anonymous someone!! said...

hi everyone..does anyone know how to make ur own flash box for bebo..which includes photos n a song of ur choice??help plz..thanx.

1/26/2007 7:47 AM  
Anonymous Anonymous said...

how do u make ur own flash box

2/20/2007 11:12 AM  
Anonymous Anonymous said...

Hae how do i umm save a video off beo into my own computer so i can edit it??

4/17/2007 8:31 PM  
Anonymous Anonymous said...

whenever i try to click on the flash box thing to try and upload. it freezes.. and im on a good connection and stuff.. is there anyway i can jst paste code into one of the text boxes?

7/01/2007 4:23 PM  
Anonymous craig said...

where can i get music videos that will play automatically on my bebo flashbox when my page loads, this does not work with youtube.

7/25/2007 12:30 AM  
Anonymous Anonymous said...

i got a good question for ya.. how do you find out what the youtube link was originally from the bebo.. i found a video with a song i want on my phone, but to do that i gta first find out the youtube link then rip the music.. could you possibly send the answer to my email?? nice-shoes-lets-fuk@hotmail.com

7/27/2007 5:56 AM  
Anonymous Anonymous said...

Hi Guys can any1 help???


I jus RE-Signed up to bebo after deleting my previous account.

Im having a problem that is :

I CANT AUTOPLAY BEBO (flash) Vids has that feature been removed for new account can somebody please help me thanks. :)

8/16/2007 3:20 AM  
Anonymous Anonymous said...

heya how do u make ur own bebo video with music and pictures and every thing wb when u can much luv xoxo

8/22/2007 3:12 AM  
Anonymous Anonymous said...

Hiya. I Dunno whether this is just a video question and answer thing but i have a question about uploading photos onto Bebo. I am trying to upload a profile photo and they are all 'jpeg' images but Bebo is telling me their not when they clearly are (i've checked properties and they say that they are jpeg format)any solutions as to how i can even get a profile pic on there? Thanks

11/02/2007 10:05 AM  
Blogger shaner said...

Yeah, this is generally just for videos. I don't have a bebo profile anymore so your best bet would be to check out the help section on bebo.

Thanks,

Shaner

11/19/2007 4:25 AM  

Post a Comment

Links to this post:

Create a Link

<< Home